OCS 2007 R2 Schema Prep Failure “failure occurred attempting to check the schema state. please ensure active directory is reachable"

A customer called in today with an issue preparing their OCS 2007 R2 environment. The customer had previously started installation on a 2008 R2 server, and started over with a 2008 R1 server. They had only completed the Active Directory Preparations prior to starting over. The issue was when they started on the server they were unable to see the schema prep, they were receiving this error in the install GUI:

ocsschemaprepfailure

A few interesting things here, the machine is joined to the domain, I could contact all domain controllers, I could modify the schema using the schema MMC snapin. However, the OCS install run via command line or GUI would not contact active directory.

Through some quick googling I found that the installer queries the SRV records for contacting the PDC in active directory. This SRV record is:

_ldap._tcp.pdc._msdcs. DnsDomainName

After pointing to a DNS issue, the customer realized their server was pointing to a public DNS server, not an active directory integrated server, which did not have the SRV records needed to perform these tasks. Once the DNS server was changed, the installer read the Active Directory Preparation as Completed and you could do a proper nslookup on those SRV records

srvldapquery

Advertisements

About Randy Wintle

Unified Communications Architect

Posted on January 14, 2010, in Conferencing, LCS, Microsoft, OCS, OCS 2007 R2, Unified Communications. Bookmark the permalink. 9 Comments.

  1. Hi Randy,

    I am also facing similar issue, but this is when I tried installing OCS R2 at my branch office which is connected with MPLS link to my HO and Branch office has local AD, which sync with HO AD periodically.
    I tried giving the DNS of my HO also still its giving me same error.
    can you please help me out.

    Thanks.

    • I’m haveing the exact same issue of Mantu Jha. My AD is a local and replicates from master periodically. Does anyone knows how to resolve?

      Thx

  2. System Administrator

    I got this error and realized I was logged in as the local administrator, not with the domain admin account. Hope this helps

  3. Thank You So Much. Had the same problem…..

  4. i had yhe same proobleme…but i don’t know how resolviing it??

  5. how to resoolb the proobleem pliiiz??!!

  6. Login in your main domain admin account and not to the local admin machine account.

    IE if your domain is microsoft.local

    login as microsoft\administrstor and put your passsword in.

Leave a Reply to System Administrator Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: