Error When Installing UM Role on Exchange 2010 SP1

11/12/2010 12:31:24.0997] [2] Active Directory session settings for ‘install-umservice’ are: View Entire Forest: ‘True’, Configuration Domain Controller: domaincontrollerfqdn, Preferred Global Catalog: “domaincontrollerfqdn”, Preferred Domain Controllers: ‘{ domaincontrollerfqdn }’
[11/12/2010 12:31:24.0997] [2] Beginning processing install-UMService
[11/12/2010 12:31:26.0012] [2] [WARNING] An unexpected error has occurred and a Watson dump is being generated: There are no more endpoints available from the endpoint mapper. (Exception from HRESULT: 0x800706D9)
[11/12/2010 12:31:26.0012] [2] [ERROR] There are no more endpoints available from the endpoint mapper. (Exception from HRESULT: 0x800706D9)
[11/12/2010 12:31:27.0668] [1] The following 1 error(s) occurred during task execution:
[11/12/2010 12:31:27.0668] [1] 0.  ErrorRecord: There are no more endpoints available from the endpoint mapper. (Exception from HRESULT: 0x800706D9)
[11/12/2010 12:31:27.0668] [1] 0.  ErrorRecord: System.Runtime.InteropServices.COMException (0x800706D9): There are no more endpoints available from the endpoint mapper. (Exception from HRESULT: 0x800706D9)
   at Interop.NetFw.INetFwRules.Add(NetFwRule rule)
   at Microsoft.Exchange.Security.WindowsFirewall.ExchangeFirewallRule.Add()
   at Microsoft.Exchange.Configuration.Tasks.ManageService.Install()
   at Microsoft.Exchange.Management.Tasks.UM.InstallUMService.InternalProcessRecord()
   at Microsoft.Exchange.Configuration.Tasks.Task.ProcessRecord()
   at System.Management.Automation.CommandProcessor.ProcessRecord()

 

When running the wizard to add the UM role to your Exchange 2010 Sp1 server, you may have this error appear in the install wizard:

ErrorRecord: System.Runtime.InteropServices.COMException (0x800706D9): There are no more endpoints available from the endpoint mapper. (Exception from HRESULT: 0x800706D9)

If you take a look at the Exchange setup log, it is trying to add firewall rules, and fails, and kills the install. If your windows firewall service is not running, you must start it.  Re run the installation with windows firewall running, and all is fine Smile

About Randy Wintle

Unified Communications Architect

Posted on November 12, 2010, in Enterprise Voice, Exchange 2010, Exchange UM, Lync, Microsoft, OCS 2007 R2, Server 2008 R2, Unified Communications. Bookmark the permalink. 4 Comments.

  1. Lol, epic fail! And they call it Trustworthy computing :))

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: